This WordPress Plugin introduces advanced citation capabilities to the WordPress Block Editor.

Overview

Citations for WordPress

🏗 Build & Deploy

This WordPress plugin introduces practical citation functionality to the WordPress Block Editor, aiming to streamline the process of adding references to your content.

This WordPress project is made with love and brought to you by the folks of WP Munich and Luehrsen // Heinrich.

Features

  1. Cite Rich Text Format: This feature lets users mark citations in their text and assign them a specific source. This makes adding citations straightforward, enhancing the clarity and reliability of your content.
  2. Bibliography Block: This plugin also offers a bibliography block that displays all referenced sources. The plugin creates links between your in-text citations and their corresponding sources in the bibliography block, making it easier for readers to find and check your references.

How to use this WordPress Plugin

Installation

From within WordPress (when the Plugin is reviewed and released)

  1. Visit 'Plugins > Add New'
  2. Search for 'Citations'
  3. Activate 'Citations' from your Plugins page.

Manually

  1. Download the citations.zip from our most recent release.
  2. Visit 'Plugins > Add New'
  3. Click the 'Add new' button.
  4. Upload the citations.zip archive to your WordPress
  5. Activate the 'Citations' plugin through the 'Plugins' menu in WordPress

Creating In-Text Citations

  1. Navigate to the Posts section of your WordPress dashboard.
  2. Click on the Add New button to create a new post, or select an existing post where you want to add citations.
  3. Type your content into the WordPress Block Editor.
  4. To add a citation, first highlight the text that you want to cite.
  5. With the text still highlighted, find and click on the "Cite" format from the rich text format toolbar.
  6. A pop-up will appear asking you to define your source. Input the source information into the fields provided.

Adding a Bibliography Block

  1. Click on the + icon in the editor toolbar to add a new block to your post.
  2. Search for "Bibliography" in the block search bar.
  3. Click on the Bibliography block to add it to your post.
  4. The Bibliography block will automatically populate with the sources of all the in-text citations you've added to your post. Each citation in the text is linked to its corresponding source in the bibliography, allowing readers to easily check your references.

Editing Citations and Sources

  1. To edit a citation or source, click on the citation in the text.
  2. Make the necessary changes in the pop-up that appears.
  3. Click on Save or Update to apply your changes.

Using the Demo-Pattern

  1. Click on the + icon in the editor toolbar to add a new pattern to your post.
  2. Search for "Citations Demo" in the pattern search bar.
  3. Click on the "Citations Demo" pattern to add it to your post.
  4. A few lines of filler text with pre-defined citations and a bibliography block will appear in your post content.

Screenshots

The Bibliography Block The Citations Rich Text Format
The Bibliography Block The Citations Rich Text Format

Contributing

Every bit of help is highly appreciated. Even if you don't code you can file an issue and help us find bugs or shape new features. Please see the CONTRIBUTING.md on how to contribute.

License

This plugin is licensed under GNU General Public License v2 (or later).

Changelog

Please find the current changelog here.

Comments
  • Bump webpack from 5.85.0 to 5.86.0

    Bump webpack from 5.85.0 to 5.86.0

    Bumps webpack from 5.85.0 to 5.86.0.

    Release notes

    Sourced from webpack's releases.

    v5.86.0

    New Features

    Bug Fixes

    Developer Experience

    Dependencies & Maintenance

    New Contributors

    Full Changelog: https://github.com/webpack/webpack/compare/v5.85.1...v5.86.0

    v5.85.1

    Bug Fixes

    • Fix bug in handling barrel imports (#17305) by @​bworline in webpack/webpack#17307 - NOTE: An internal API BasicEvaluatedExpression.getMemberRangeStarts has been changed to BasicEvaluatedExpression.getMemberRanges, please see type definition changes and the pull request for more information.

    Dependencies & Maintenance

    Full Changelog: https://github.com/webpack/webpack/compare/v5.85.0...v5.85.1

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 1
  • Bump webpack from 5.85.0 to 5.85.1

    Bump webpack from 5.85.0 to 5.85.1

    Bumps webpack from 5.85.0 to 5.85.1.

    Release notes

    Sourced from webpack's releases.

    v5.85.1

    Bug Fixes

    • Fix bug in handling barrel imports (#17305) by @​bworline in webpack/webpack#17307 - NOTE: An internal API BasicEvaluatedExpression.getMemberRangeStarts has been changed to BasicEvaluatedExpression.getMemberRanges, please see type definition changes and the pull request for more information.

    Dependencies & Maintenance

    Full Changelog: https://github.com/webpack/webpack/compare/v5.85.0...v5.85.1

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 1
  • Bump webpack-cli from 5.1.1 to 5.1.3

    Bump webpack-cli from 5.1.1 to 5.1.3

    Bumps webpack-cli from 5.1.1 to 5.1.3.

    Release notes

    Sourced from webpack-cli's releases.

    v5.1.3

    5.1.3 (2023-06-04)

    Bug Fixes

    v5.1.2

    5.1.2 (2023-06-04)

    Bug Fixes

    • improve check for custom webpack and webpack-dev-server package existance (0931ab6)
    • improve help for some flags (f468614)
    • improved support for .cts and .mts extensions (a77daf2)
    Changelog

    Sourced from webpack-cli's changelog.

    5.1.3 (2023-06-04)

    Bug Fixes

    5.1.2 (2023-06-04)

    Bug Fixes

    • improve check for custom webpack and webpack-dev-server package existance (0931ab6)
    • improve help for some flags (f468614)
    • improved support for .cts and .mts extensions (a77daf2)
    Commits
    • 7899c39 chore(release): publish new version
    • bb4f8eb fix: regression for custom configurations (#3834)
    • 14b9c18 docs: update changelog
    • e879ce4 chore(release): publish new version
    • beea1d1 refactor: use type for types (#3832)
    • 0931ab6 fix: improve check for custom webpack and webpack-dev-server package existance
    • fa0553c chore(deps-dev): bump @​types/jest from 29.5.1 to 29.5.2 (#3825)
    • a77daf2 fix: improved support for .cts and .mts extensions
    • 73bd2cc chore(deps-dev): bump webpack-bundle-analyzer from 4.8.0 to 4.9.0 (#3829)
    • a5b49ab chore(deps-dev): bump typescript from 5.0.4 to 5.1.3 (#3828)
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 1
  • Bump wp-cli/wp-cli-bundle from 2.7.1 to 2.8.0

    Bump wp-cli/wp-cli-bundle from 2.7.1 to 2.8.0

    Bumps wp-cli/wp-cli-bundle from 2.7.1 to 2.8.0.

    Release notes

    Sourced from wp-cli/wp-cli-bundle's releases.

    Release v2.8.0

    See https://make.wordpress.org/cli/2023/05/31/wp-cli-v2-8-0-release-notes/

    Commits
    • c6edb2a Merge pull request #550 from wp-cli/release-2-8-0
    • 3af8aef Update dependencies
    • 9a9787c Merge pull request #549 from wp-cli/update-composer-lock-file-2023-05-31-b
    • 5918fc6 Update Composer lock file
    • bb2455c Merge pull request #548 from wp-cli/update-composer-lock-file-2023-05-31
    • a6e168e Update Composer lock file
    • b6eec08 Update file(s) from wp-cli/.github
    • b9eb82d Bump wp-cli/core-command from 2.1.11 to 2.1.12 (#545)
    • 3bfb4ed Merge pull request #546 from wp-cli/dependabot/composer/wp-cli/checksum-comma...
    • df3c3cf Merge pull request #547 from wp-cli/dependabot/composer/wp-cli/cron-command-2...
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies php 
    opened by dependabot[bot] 1
  • Bump postcss-preset-env from 8.4.1 to 8.4.2

    Bump postcss-preset-env from 8.4.1 to 8.4.2

    Bumps postcss-preset-env from 8.4.1 to 8.4.2.

    Changelog

    Sourced from postcss-preset-env's changelog.

    8.4.2 (June 1, 2023)

    • Updated @csstools/postcss-progressive-custom-properties to 2.3.0 (minor)
    • Updated postcss-custom-properties to 13.2.0 (minor)
    • Updated @csstools/postcss-color-function to 2.2.3 (patch)
    • Updated @csstools/postcss-color-mix-function to 1.0.3 (patch)
    • Updated @csstools/postcss-gradients-interpolation-method to 3.0.6 (patch)
    • Updated @csstools/postcss-ic-unit to 2.0.4 (patch)
    • Updated @csstools/postcss-media-minmax to 1.0.3 (patch)
    • Updated @csstools/postcss-media-queries-aspect-ratio-number-values to 1.0.3 (patch)
    • Updated @csstools/postcss-oklab-function to 2.2.3 (patch)
    • Updated @csstools/postcss-relative-color-syntax to 1.0.1 (patch)
    • Updated postcss-color-functional-notation to 5.1.0 (minor)
    • Updated postcss-custom-media to 9.1.4 (patch)
    • Updated postcss-double-position-gradients to 4.0.4 (patch)
    • Updated postcss-lab-function to 5.2.3 (patch)
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 1
  • Bump webpack from 5.83.1 to 5.84.1

    Bump webpack from 5.83.1 to 5.84.1

    Bumps webpack from 5.83.1 to 5.84.1.

    Release notes

    Sourced from webpack's releases.

    v5.84.1

    Bug Fixes

    Dependencies & Maintenance

    Full Changelog: https://github.com/webpack/webpack/compare/v5.84.0...v5.84.1

    v5.84.0

    New Features

    Bugfixes

    Developer Experience

    Dependencies & Maintenance

    New Contributors

    Full Changelog: https://github.com/webpack/webpack/compare/v5.83.1...v5.84.0

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 1
  • Bump css-loader from 6.7.3 to 6.7.4

    Bump css-loader from 6.7.3 to 6.7.4

    Bumps css-loader from 6.7.3 to 6.7.4.

    Release notes

    Sourced from css-loader's releases.

    v6.7.4

    6.7.4 (2023-05-19)

    Bug Fixes

    • bugs in css modules (c3099fb)
    • output warning when built-in CSS support enabled (#1520) (0700ce8)
    Changelog

    Sourced from css-loader's changelog.

    6.7.4 (2023-05-19)

    Bug Fixes

    • bugs in css modules (c3099fb)
    • output warning when built-in CSS support enabled (#1520) (0700ce8)
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 1
  • Bump glob from 10.2.4 to 10.2.5

    Bump glob from 10.2.4 to 10.2.5

    Bumps glob from 10.2.4 to 10.2.5.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 1
  • Bump postcss from 8.4.21 to 8.4.23

    Bump postcss from 8.4.21 to 8.4.23

    Bumps postcss from 8.4.21 to 8.4.23.

    Release notes

    Sourced from postcss's releases.

    8.4.23

    • Fixed warnings in TypeDoc.

    8.4.22

    Changelog

    Sourced from postcss's changelog.

    8.4.23

    • Fixed warnings in TypeDoc.

    8.4.22

    • Fixed TypeScript support with node16 (by Remco Haszing).
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 1
  • Bump @wordpress/env from 6.0.0 to 7.0.0

    Bump @wordpress/env from 6.0.0 to 7.0.0

    Bumps @wordpress/env from 6.0.0 to 7.0.0.

    Changelog

    Sourced from @​wordpress/env's changelog.

    7.0.0 (2023-05-10)

    Breaking Change

    • Docker containers now run as the host user. This should resolve problems with permissions arising from different owners between the host, web container, and cli container. If you still encounter permissions issues, try running npx wp-env destroy so that the environment can be recreated with the correct permissions.
    • Remove the composer and phpunit Docker containers. If you are currently using the run composer or run phpunit command you can migrate to run cli composer or run tests-cli phpunit respectively. Note that with composer, you will need to use the --env-cwd option to navigate to your plugin's directory as it is no longer the default working directory.

    New feature

    • Create an afterSetup option in .wp-env.json files for setting arbitrary commands to run after setting up WordPress when using npx wp-env start and npx wp-env clean.
    • Add a WP_ENV_AFTER_SETUP environment variable to override the afterSetup option.
    • Execute the afterSetup command on npx wp-env start after the environment is set up. This can happen when your config changes, WordPress updates, or you pass the --update flag.
    • Execute the afterSetup command on npx wp-env clean.
    • Globally install composer and the correct version of phpunit in all of the Docker containers.

    Bug fix

    • Ensure wordpress, tests-wordpress, cli, and tests-cli always build the correct Docker image.
    • Fix Xdebug while using PHP 7.2x.

    Enhancement

    • wp-env run ... now uses docker-compose exec instead of docker-compose run. As a result, it is much faster, since commands are executed against existing services, rather than creating them from scratch each time.
    • Increase the maximum upload size to 1GB.
    Commits
    • e936127 chore(release): publish
    • 717c69d Update changelog files
    • b50133e Merge changes published in the Gutenberg plugin "release/15.8" branch
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 1
  • Bump terser-webpack-plugin from 5.3.7 to 5.3.8

    Bump terser-webpack-plugin from 5.3.7 to 5.3.8

    Bumps terser-webpack-plugin from 5.3.7 to 5.3.8.

    Release notes

    Sourced from terser-webpack-plugin's releases.

    v5.3.8

    5.3.8 (2023-05-06)

    Bug Fixes

    Changelog

    Sourced from terser-webpack-plugin's changelog.

    5.3.8 (2023-05-06)

    Bug Fixes

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 1
  • Bump webpack from 5.85.0 to 5.87.0

    Bump webpack from 5.85.0 to 5.87.0

    Bumps webpack from 5.85.0 to 5.87.0.

    Release notes

    Sourced from webpack's releases.

    v5.87.0

    New Features

    Bug Fixes

    Developer Experience

    Dependencies & Maintenance

    New Contributors

    @​aboktor made their first contribution in #16991 #16989 @​silverwind made their first contribution in #17339 via #17329

    Full Changelog: https://github.com/webpack/webpack/compare/v5.86.0...v5.87.0

    v5.86.0

    New Features

    Bug Fixes

    Developer Experience

    Dependencies & Maintenance

    New Contributors

    ... (truncated)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 0
  • Bump postcss-preset-env from 8.4.1 to 8.5.0

    Bump postcss-preset-env from 8.4.1 to 8.5.0

    Bumps postcss-preset-env from 8.4.1 to 8.5.0.

    Changelog

    Sourced from postcss-preset-env's changelog.

    8.5.0 (June 14, 2023)

    • Add warning when using the deprecated @nest rule
    • Updated @csstools/postcss-relative-color-syntax to 1.0.2 (patch)
    • Updated postcss-nesting to 11.3.0 (minor)

    8.4.2 (June 1, 2023)

    • Updated @csstools/postcss-progressive-custom-properties to 2.3.0 (minor)
    • Updated postcss-custom-properties to 13.2.0 (minor)
    • Updated @csstools/postcss-color-function to 2.2.3 (patch)
    • Updated @csstools/postcss-color-mix-function to 1.0.3 (patch)
    • Updated @csstools/postcss-gradients-interpolation-method to 3.0.6 (patch)
    • Updated @csstools/postcss-ic-unit to 2.0.4 (patch)
    • Updated @csstools/postcss-media-minmax to 1.0.3 (patch)
    • Updated @csstools/postcss-media-queries-aspect-ratio-number-values to 1.0.3 (patch)
    • Updated @csstools/postcss-oklab-function to 2.2.3 (patch)
    • Updated @csstools/postcss-relative-color-syntax to 1.0.1 (patch)
    • Updated postcss-color-functional-notation to 5.1.0 (minor)
    • Updated postcss-custom-media to 9.1.4 (patch)
    • Updated postcss-double-position-gradients to 4.0.4 (patch)
    • Updated postcss-lab-function to 5.2.3 (patch)
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 0
  • Bump @wordpress/babel-plugin-import-jsx-pragma from 4.17.0 to 4.18.0

    Bump @wordpress/babel-plugin-import-jsx-pragma from 4.17.0 to 4.18.0

    Bumps @wordpress/babel-plugin-import-jsx-pragma from 4.17.0 to 4.18.0.

    Changelog

    Sourced from @​wordpress/babel-plugin-import-jsx-pragma's changelog.

    4.18.0 (2023-06-07)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 0
  • Bump @wordpress/eslint-plugin from 14.7.0 to 14.8.0

    Bump @wordpress/eslint-plugin from 14.7.0 to 14.8.0

    Bumps @wordpress/eslint-plugin from 14.7.0 to 14.8.0.

    Release notes

    Sourced from @​wordpress/eslint-plugin's releases.

    14.8.0

    Changelog

    Enhancements

    Block Library

    • Add a current-menu-ancestor class to navigation items. (40778)
    • Page List Block: Adds a longdash tree to the parent selector. (46336)
    • Page List Block: Hide page list edit button if no pages are available. (46331)
    • Page List: Add convert panel to Inspector Controls when within Nav block. (46352)
    • Page List: Prevent users from adding inner blocks to Page List. (46269)
    • Reusable block: Pluralize the message "Convert to regular blocks" depending on the number of blocks contained. (45819)
    • Add page list to Link UI transforms in Nav block. (46426)
    • Heading Block: Don't rely on the experimental selector anymore. (46284)
    • Media & Text Block: Create undo history when media width is changed. (46084)
    • Navigation block: Add location->primary to fallback nav creation for classic menus. (45976)
    • Navigation block: Update fallback nav creation to the most recently created menu. (46286)
    • Navigation: Add a 'open list view' button. (46335)
    • Navigation: Removes the header from the navigation list view in the experiment. (46070)
    • Query: Remove color block supports. (46147)
    • Table block: Make figcaption styles consistent between editor and front end. (46172)
    • List/quote: Unwrap inner block when pressing Backspace at start. (45075)

    Inspector Controls

    • Sidebar Tabs: Refine the use of inspector tabs and disable filters for Nav blocks. (46346)
    • Sidebar Tabs: Use editor settings to override display. (46321)
    • Summary panel: Try improving spacing and grid. (46267)

    Global Styles

    • Add Style Book to Global Styles. (45960)
    • Add block preview component in global styles. (45719)
    • Move border from layout to own menu. (45995)
    • Add a css style to theme.json to allow setting of custom css strings. (46255)
    • Expose before filter hook in useSettings for injecting block settings in the editor. (45089)
    • Global styles: Add custom CSS panel to site editor. (46141)

    Site Editor

    • Reorganize the site editor to introduce Browse Mode. (44770)
    • Allow adding new templates and template parts directly from the sidebar. (46458)
    • Synchronize the sidebar state in the URL. (46433)
    • Try template drill down on the shell sidebar (browse mode). (45100)

    Block Editor

    • Update the synced block hover styles in Inserter. (46442)
    • Add new selector getLastInsertedBlockClientId. (46531)
    • Block editor: Hide fixed contextual toolbar. (46298)
    • Inserter: Pattern title tooltip. (46419)
    • useNestedSettingsUpdate: Prevent unneeded syncing of falsy templateLock values. (46357)
    • Design: Augmented shadows for modals and popovers. (46228)

    ... (truncated)

    Changelog

    Sourced from @​wordpress/eslint-plugin's changelog.

    14.8.0 (2023-06-07)

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 0
  • Bump @wordpress/env from 8.0.0 to 8.1.0

    Bump @wordpress/env from 8.0.0 to 8.1.0

    Bumps @wordpress/env from 8.0.0 to 8.1.0.

    Changelog

    Sourced from @​wordpress/env's changelog.

    8.1.0 (2023-06-07)

    New feature

    • Execute the local package's wp-env instead of the globally installed version if one is available.

    Bug fix

    • Run useradd with -l option to prevent excessive Docker image sizes.
    Commits
    • a92f606 chore(release): publish
    • 882d769 Update changelog files
    • fe8b591 Merge changes published in the Gutenberg plugin "release/16.0" branch
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 0
  • Bump webpack-cli from 5.1.1 to 5.1.4

    Bump webpack-cli from 5.1.1 to 5.1.4

    Bumps webpack-cli from 5.1.1 to 5.1.4.

    Release notes

    Sourced from webpack-cli's releases.

    v5.1.4

    5.1.4 (2023-06-07)

    Bug Fixes

    • multi compiler progress output (f659624)

    v5.1.3

    5.1.3 (2023-06-04)

    Bug Fixes

    v5.1.2

    5.1.2 (2023-06-04)

    Bug Fixes

    • improve check for custom webpack and webpack-dev-server package existance (0931ab6)
    • improve help for some flags (f468614)
    • improved support for .cts and .mts extensions (a77daf2)
    Changelog

    Sourced from webpack-cli's changelog.

    5.1.4 (2023-06-07)

    Bug Fixes

    • multi compiler progress output (f659624)

    5.1.3 (2023-06-04)

    Bug Fixes

    5.1.2 (2023-06-04)

    Bug Fixes

    • improve check for custom webpack and webpack-dev-server package existance (0931ab6)
    • improve help for some flags (f468614)
    • improved support for .cts and .mts extensions (a77daf2)
    Commits
    • e07f0e5 chore(release): publish new version
    • 0345c6f chore(deps-dev): bump @​typescript-eslint/parser from 5.59.8 to 5.59.9 (#3839)
    • f659624 fix: multi compiler progress output
    • 0d1ff01 chore(deps-dev): bump webpack from 5.85.0 to 5.85.1 (#3837)
    • a7ec146 chore(deps-dev): bump @​typescript-eslint/eslint-plugin (#3838)
    • 9464635 chore(deps-dev): bump eslint from 8.41.0 to 8.42.0 (#3835)
    • cf1796f docs: update changelog
    • 7899c39 chore(release): publish new version
    • bb4f8eb fix: regression for custom configurations (#3834)
    • 14b9c18 docs: update changelog
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    dependencies javascript 
    opened by dependabot[bot] 0
Releases(v0.0.20)
Owner
Luehrsen // Heinrich
Agentur fĂĽr Medienkommunikation - WordPress, Social, Print
Luehrsen // Heinrich
A PocketMine-MP plugin that replaces a block to another block when breaks, then back to the original block after a certain time

BlockReplacer A PocketMine-MP plugin that replaces a block to another block when breaks, then back to the original block after a certain time How to I

AIPTU 11 Sep 2, 2022
WordPress plugin boilerplate using React and Block Editor components.

PluginWP Foundation ?? UNDER DEVELOPMENT ?? This code serves as a starting point for building a WordPress plugin using React and the block editor comp

JR Tashjian 5 Dec 8, 2022
A plugin to disable the drop cap option in Gutenberg editor paragraph block. This is version 2.

Disable Drop Cap (v2) A plugin to disable drop cap option in the Gutenberg editor block editor paragraph block. Note for WordPress 5.8 With WordPress

Johannes Siipola 4 Jan 4, 2022
Advanced Laravel models filtering capabilities

Advanced Laravel models filtering capabilities Installation You can install the package via composer: composer require pricecurrent/laravel-eloquent-f

Andrew Malinnikov 162 Oct 30, 2022
A Laravel package that introduces a clean object based alternative to Laravel route files.

Laravel Route Registrars This package introduces a clean object based way to define your routes in a Laravel application. A tutorial on the basic prem

Ollie Codes 22 Nov 25, 2022
WordPress entities creation library (CPT, CT, native option page, ACF option page, user role, block pattern category, block category…)

WordPress entities creation library (CPT, CT, native option page, ACF option page, user role, block pattern category, block category…)

LoĂŻc Antignac 2 Jul 25, 2022
Create custom WordPress routes and redirects, restrict access by roles and/or capabilities. Routes made simple

Create custom WordPress routes and redirects, restrict access by roles and/or capabilities. Routes made simple

Joan 9 Oct 10, 2022
An example starter theme and block-type plugin that use @wordpress/scripts for JS & CSS

Brad’s Boilerplate This repo contains one folder that is an example theme, and another folder that is an example block-type plugin. Both folders use t

Brad Schiff 185 Dec 26, 2022
WordPress plugin to make it easier to create block patterns.

=== Templets === Contributors: mkaz Tags: block patterns, patterns Requires at least: 5.8 Tested up to: 5.8 Requires PHP: 7.3 Stable tag: 0.2.0 Licens

Marcus Kazmierczak 9 Jan 3, 2023
A WordPress plugin that displays proxied war news from the free world to Russian IP address visitors with option to block further access.

A WordPress plugin that displays proxied war news from the free world to Russian IP address visitors with option to block further access.

null 5 Jul 15, 2022
Free WordPress Gutenberg block-type Plugin Boilerplate for Developers.

ClioWP Blocks Boilerplate ClioWP Blocks Boilerplate is a Free WordPress Gutenberg block-type Plugin Boilerplate for Developers. Links Website https://

Christos Pontikis 6 Dec 29, 2022
PHP cache library, with adapters for e.g. Memcached, Redis, Couchbase, APC(u), SQL and additional capabilities (e.g. transactions, stampede protection) built on top.

Donate/Support: Documentation: https://www.scrapbook.cash - API reference: https://docs.scrapbook.cash Table of contents Installation & usage Adapters

Matthias Mullie 295 Nov 28, 2022
Allow multiple options for Magento 2 checkout layout. Provides capabilities to AB test checkout changes and more.

Aimes_CheckoutDesigns Features Please note: This module is currently still considered a proof of concept. This module provides the ability to change c

Rob Aimes 30 Aug 8, 2022
Add mocking capabilities to Pest or PHPUnit

This repository contains the Pest Plugin Mock. The Mocking API can be used in regular PHPUnit projects. For that, you just have to run the following c

PEST 16 Dec 3, 2022
Magento 2 Module to add simple image resizing capabilities in all blocks and .phtml templates

Magento 2 Image Resizer Magento 2 Module to add simple image resizing capabilities in all blocks and .phtml templates Installation $ composer require

Stämpfli AG 88 Apr 18, 2022
The FileLocator library was created to provide file locating capabilities to a larger project

File Locator A simple file locator library. Summary The FileLocator library was created to provide file locating capabilities to a larger project. It

KHerGe - Archived Projects 20 Dec 22, 2021
Symfony bundle which provides OAuth 2.0 authorization/resource server capabilities

Symfony bundle which provides OAuth 2.0 authorization/resource server capabilities. The authorization and resource server actors are implemented using the thephpleague/oauth2-server library.

Trikoder 253 Dec 21, 2022
Enables full-text search capabilities in Winter.

Search Plugin Adds full-text searching capabilities to Winter, built on the foundations of Laravel Scout. The plugin acts primarily as a wrapper for L

Winter CMS 5 Dec 20, 2022
An opinionated extension package for Laravel Orchid to extend its table handling capabilities, and some further useful helper methods.

OrchidTables An opinionated extension package for Laravel Orchid to extend its table handling capabilities, and some further useful helper methods. In

null 25 Dec 22, 2022